Reset Search
 

 

Article

Hyper 212 LED AMD AM4 Compatibility

« Go Back

Information

 
Answer
      1. Why is my Hyper 212 LED not compatible with AM4?
Due to the design limitation, the AM4 upgrade kit is only compatible with the new Hyper 212 LED.
There are two ways to find out whether you have the latest model of the Hyper 212 LED AM4:

      1.1.Check whether your retail box has the sticker - “supports socket Intel LGA 1151 AMD AM4.”
User-added image

User-added image

      1.2. Your Hyper 212 LED should have two slits on the base (top image)
 
User-added image
 


     2. Will I have mechanical interference when I use AM4 upgrade kit?
If you have issues, you can adjust the orientation of the upgrade kit depending on your motherboard layout.
Note that oversized RAM might run into the AM4 upgrade kit.
 

Feedback

 

Was this article helpful?


   

Feedback

Please tell us how we can make this article more useful.

Characters Remaining: 255